Plex Media Server v0.9.7.7 - Fixes... - Plex Blog

Plex Media Server v0.9.7.7 – Fixes…

| 04 Dec 2012 | by 89 Comments

My, it’s been a busy two weeks in Plexville, since the Plex/Sync launch. We are super happy with how the launch went; after working on it for literally months, in secret, in a damp basement (with Internet access), it was honestly hard not to have a bit of anxiety when we finally released it. But people seem to love it, and – normal first-release bugs aside – it seems to be working really well. We released three more media server updates over the last two weeks to address the most pressing issues, and now we’re pushing a new release out to everyone with all the collected fixes and a few more.

As usual, our beloved community sums it up better than we ever could:

Plexsync

A note for all you Android lovers, we’re closing in on releasing the first preview of PlexSync for Android. We know there are lots of you eager to sync your media to your droidy devices, and you’ll be able to do so in short order. Short. Like the dwarf guy from Game of Thrones. Winter is…almost here.

Plex/Web also continues to progress at an amazing pace. In the past two weeks we pushed couple of updates which added all sort of cool stuff like alphanumeric paging, which makes it even easier to browse giant media libraries:

Screenshot 12 4 12 12 29 AM

And we’re also added some social features; you can manage your list of friends, and share to Facebook and recommend videos to your friends right from Plex/Web.

Screenshot 12 4 12 12 33 AM

The other big news is that Samsung finally (finally!) approved the update of the Plex for Samsung app, which supports 2012 models. There’s an emoticon for that and it’s something like this: /

The new media server release is out, and can be downloaded from the usual spot. Here’s a list of the fixes contained within:

  • (Non OS X) Automatically merge movies when appropriate.
  • Fix a crash if there are any unexpected files in the transcode directory.
  • Fix a crash when scanning photos with certain EXIF data.
  • (OS X) Fixed an evil crash which occurred roughly once every day.
  • Don’t allow clients to cache segments, fixes IE10 video playback issue.
  • A few crashes that could be caused by proxies getting in the middle between server and myPlex.
  • (PlexSync) Added iPad 4 profile, fixed iPad 3 profile.
  • (PlexSync) Sync transcoder now works on 32-bit CPUs on Snow Leopard.
  • (PlexSync) Allow DirectPlay sync with subtitles (e.g. MP4/TTXT).
  • (PlexSync) Scrobble and library media addition/deletion kicks off sync worker. Fixes sync of recently added items.
  • (PlexSync) We skip over any invalid sync items instead of completely failing.
  • (PlexSync) Fix failed downloads of art/posters in some cases.
  • (PlexSync) Synced media subsections weren’t always in the right order.
  • (PlexSync) Video bitrate limit on ‘highest’ quality was removed.
  • (PlexSync) Fixed broken XML in some sync profiles
  • (PlexSync) Fixed an issue where the sync profile name was not constructed correctly.
  • (PlexSync) Work-around that the client sent the wrong model name
  • (PlexSync) Some sync profiles contained invalid transcoder options
  • (Linux) Pass along LANG variable, to assist agents who need to read filesystem.
  • (Linux) Crash signing out of myPlex or un-publishing server.
  • (Linux) Add the photo transcoder in for ARM architectures.
  • (Linux) Fixes for start-up scripts on Fedora and ReadyNAS
  • (Linux) Upgrade Sync Transcoder to support progress information.
  • (API) Fixes to /firstCharacter filters
  • (API) Allow filtering filters by resolution/unwatched, fixes filter issue.
  • (API) Don’t limit tag queries by metadata type if we have condition passed in.
  • (API) Fix when filtering on unwatched in /firstCharacter endpoint.
  • (API) Allow filter endpoints to use type in queries (e.g. album genres).

Not to be one-dimensional with the Barkley photos, but he really insists on his ocean time. I’m pretty sure his webbed paws are an indication that he’s a semi-aquatic mammal.

IMG 2703 IMG 2699

 

FacebookTwitterGoogle+LinkedIn
Share this

89 Comments so far

  1. jarrod December 4th, 2012 12:49 am

    thanks elan, i voted

  2. zAo December 4th, 2012 12:50 am

    Thanks again.

    Any update on the iOS app? Still can’t stream series.

  3. tobias December 4th, 2012 12:56 am

    Update to iOS is in Apples review queue.

  4. drh December 4th, 2012 12:57 am

    lovely jubbly

  5. Roger December 4th, 2012 1:39 am

    Hey, great work, as always, congrats!

    May it be possible to give the feature back that we can use the security for direct access from remote?
    In the iOS App I’m still able to enter Username and Password ( not myPlex) but where can I define it on the server?

    Thx for your answer!

    Cheers

  6. Fredrik December 4th, 2012 2:02 am

    Does anyone know why I can’t access my iTunes library via the web client?

  7. SoylentGraham December 4th, 2012 2:09 am

    Plexsync works brilliantly!

    I just have 2 things in my wishlist; (Is there somewhere more appropriate for this? like a getsatisfaction suggestion box?)

    1) I just wish PMS could auto-update as I manage my server over VNC which is a little slow :)

    2) An interface to see unmatched files so I can correct them remotely!

    Plex has been executed so well!

  8. Sebastian December 4th, 2012 2:47 am

    Great, thanks!!

  9. eric December 4th, 2012 3:38 am

    @Frederik The iTunes channel is not supported by Plex/Web yet.

  10. BiNAX December 4th, 2012 3:48 am

    I like it so much!
    Thank you very much!!!!

    I’m planning to subscribe to PlexPass in the naxt weeks.

    Great work Elan!

  11. Denys06 December 4th, 2012 3:53 am

    Hello, thank you very very much for your Samsung 2012 compatibility !

    I have a bug for MKV 3D. I can’t activate 3D Slide by Slide in 3D Option. I can activate only 2D => 3D. Can you resolve it in next version :) ?

    Thank

  12. Dean December 4th, 2012 4:13 am

    Firstly i would like to say how much I like using Plex to view my movies. The only thing that I would change are:

    1. If there is a problem with a particular title, PMS just renames it. On a future fix, please ensure that PMS queries all titles that it does not recognise.

    2. IMDb at present shows mostly irrelevant information. I am not interested in how much it made at the box office or whether it was a flop. Just want to know the information relating to the actual film/TV show (basically the information found on the back of the DVD box).

    Hope that you are able to resolve these issues.

    Cheers.

  13. Øyvind Thoresen December 4th, 2012 4:37 am

    Will The Windows Phone client be updated With The newfeatures?

  14. Ranswick December 4th, 2012 5:10 am

    Thanks a lot!
    A newsletter (ok i am old fashioned) would be nice for new releases.

  15. BatMac December 4th, 2012 5:22 am

    I hope all of you get to RELAX one in a while like Barkley in that last photo!

    Great work!!!

  16. André Almeida December 4th, 2012 5:43 am

    Subtitles in TV Series (LINUX – ubuntu 12.04 x64) don’t work…
    In movies, works fine.

    tvseries.avi
    tvseries.srt

    In windows 7, works fine.
    Any help?

  17. Optimusb December 4th, 2012 6:10 am

    Sounds like a nice feature. Although I’m still not going to pay to beta test software then turn around and have to pay again for a monthly subscription.

  18. Brad December 4th, 2012 6:43 am

    Awesome news about the samsung app. I am in the market for a new blu ray right now. Any word on what devices will be compatible and also what the best compatible device would be???

    Thanks

  19. Bruce Dumes December 4th, 2012 7:16 am

    Ah, I am SOOOOOO happy! The evil OS X daily crash bug has been plaguing me terribly. Thank you so much!

  20. Chris C December 4th, 2012 8:28 am

    @Dean: Try changing your metadata agent preferences so that TheMovieDB is above wikipedia/freebase/etc. TheMovieDB tends to have much more conventional short summaries, which sounds like what you want. You’d then need to do a Forced Refresh on the section to get the content to update.

  21. Dunhillsmoker December 4th, 2012 8:47 am

    By the way… IOS app 3.0.1 is out :-) Time to hit the update button on all your apple devices…

    And guys: Thanks, you R O C K !!!

  22. Sebastian December 4th, 2012 11:30 am

    Hi,

    sorry guys but where can i find the desktop client. In the download section is only the server available.

    Thanks

  23. Gumby December 4th, 2012 2:08 pm

    Thanks for the new features but please fix the AVI audiosync issue!

  24. Soli December 4th, 2012 2:21 pm

    seems the daily osx evil crash is gone. Thx!

  25. Carlos Echevarria December 4th, 2012 3:02 pm

    Awesome, can’t wait to install and test it out.

  26. free_peace_sweet December 4th, 2012 3:23 pm

    I can’t activate 3D Side by Side in 3D under the new server.

  27. kasey December 4th, 2012 4:28 pm

    can you please make it as easy as it is to add movies to myplex server for tv shows? It is so annoying to have to rename everything.

    Also for seasons of shows, can you add a play all button?

    I love plex though!!!!! Cant live without it

  28. ian December 4th, 2012 8:33 pm

    Awesome.

    RE: Samsung App: any hope of getting it to work with MyPlex? I have one of their TVs in my office at work. Being able to slack remotely would be pretty sweet. Alas, it does not grok the remote scenario…

  29. David December 5th, 2012 12:32 am

    I have tried this last version on ReadyNas and I think is working better than the previous one, not sure because the full scann of contents was already done and it was the part where I have problems with the previous version.

    However I have detected some performance problems. Where is the right place to post potential bugs? Is it here?

  30. tobias December 5th, 2012 12:40 am

    @David: try the linux forums.

  31. Pat December 5th, 2012 1:39 pm

    So – had to buy Windows 8 to test is in Vmware and yes – its awesome.
    BUT – since we all came a long way from Plex being the XBMC for Mac – can we now please work on a modern skin for my Media Center so i can get rid of XBMC :-)?

  32. Pat December 5th, 2012 1:40 pm

    Wrong one :-))) that was for Windows 8!!!

  33. Hermann December 5th, 2012 1:48 pm

    I have a problem.

    I downloaded the new PMS for Mac OS X (I have an iMac with Mountain Lion) and now I can’t manage my media, it says that I need a PlexPass. Any suggestions?

  34. brett December 5th, 2012 1:54 pm

    Streaming video quality and reliability (esp. fast-forwarding) is still not up-to-par as compared to PS3 Media Server. I would love to dump that app, but PMS just isn’t quite there yet in this regard.

  35. elan December 5th, 2012 1:55 pm
  36. Hermann December 5th, 2012 2:00 pm

    @elan

    It worked! Thank you!

  37. elan December 5th, 2012 5:28 pm

    @brett: totally agreed, we’d love to fix it up.

  38. Nick December 5th, 2012 6:53 pm

    Yeah, photo scanning working for me again! Thanks! Buying some plex apps now!

  39. eszpee December 5th, 2012 9:22 pm

    Great! Now if you could just update the OS X client so that it doesn’t freeze every now and then when the server is trying to access files on a sleeping hard drive… it happens like once a day day. :(

  40. Kruisje December 6th, 2012 12:48 am

    Superb ! Everything is working great.
    What’s the next step? An update of the OSX mediacenter app? :-)

  41. Denys06 December 6th, 2012 3:15 am

    Hello, thank you very very much for your Samsung 2012 compatibility ! I up my comment, please answer me :)

    I have a bug for MKV 3D. I can’t activate 3D Slide by Slide in 3D Option. I can activate only 2D => 3D. Can you resolve it in next version ?

    Thank

  42. ppson December 6th, 2012 7:34 am

    Any chance of seeing a Sync feature on desktop clients as well? So that you could chose to sync/download full quality movie before watching instead of streaming/transcoding from a remote server?

  43. Alex Rusinov December 6th, 2012 7:56 am

    Still can’t figure how to stop Plex from transcoding VOBs to play on PS3.

  44. Bwood December 6th, 2012 3:47 pm

    Since upgrading my LG tv media link app no longer see the plex media server

  45. Bruce December 7th, 2012 5:08 am

    Samsung 2012 TV Plex app is working great, only got to play with it for a little bit, but it was playing 1080p content perfectly with full digital audio. Great job Plex team.

  46. MichaelW December 7th, 2012 5:46 pm

    ppson – You can already do that. Just copy the file(s) you want to play to the client and add the local path and you can play it right from there.

  47. Geoff December 7th, 2012 6:06 pm

    Any chance you could push the updates through to the Synology package manager?

  48. Adam December 8th, 2012 10:26 am

    The Plex app on my Roku HD (not a Roku 2) has suddenly stopped working. When I select it, the screen just sits black for a while or the Roku tries to restart itself. All other apps work fine. This seems to have only happened since I updated the media server on my laptop. Tried deleting and re-downloading the app on the Roku but as of late last night was still giving me trouble. Thoughts?

  49. elan December 8th, 2012 11:49 am

    @Adam: Fixed in a subsequent update.

  50. Tiago December 8th, 2012 8:46 pm

    PMS dosent find subtitles in movie folders.
    Name of files, both movie an subtitle, are the same.
    Why not insert the ability to add subtitle manually to the library?
    My system is a MAC OSX Lion, PMS 0.9.7.7 and LG LM6400 04.20.19.

    Thanks!

  51. Vik December 8th, 2012 8:57 pm

    The only thing I really want that’s missing is the ability to sync file watched status between iTunes and plex.

  52. Mac-Don December 8th, 2012 11:04 pm

    In Plex/Web I cannot add art to music albums manually, it seems. Now that the Mac browser is gone, what to do??

  53. Andy December 10th, 2012 10:23 am

    Great stuff..

    However, on my iPad, I have lost subtitles. It says none after the update. Before the update, I do believe these worked fine (perhaps I remember incorrectly) and still works with other players. Movie in an MKV container and subtitles in .srt.

    Anyone got anything clever? Thanks!

  54. Mike December 10th, 2012 3:11 pm

    Simple bug – or I guess the wiki could be changed. Had “Poster.jpg” and “fanart.jpg” in a media folder, and it wasn’t picked up by the local media agent. Changed the filenames to “folder.jpg” and “background.jpg” and it found them right away. In the Wiki it says poster and fanart are acceptable. Either needs fixed in PMS or WIKI changed. – Just fyi

  55. Jacob December 14th, 2012 5:56 am

    I can’t install the package on my Synology DS411+II. Anyone else have that problem?

    Thanks!

  56. Matt December 15th, 2012 4:30 pm

    @elan – with the last update the plex web interface no longer requires you to enter your plex pass username and password. Not sure of this was a bug or intended but it was nice to have for security reasons. Please add that feature back in. Other than that Plex has been amazing keep up the great work!
    Thanks
    Matt

  57. Joshua December 15th, 2012 6:32 pm

    Plex media server has not working keeps right! everytime I download it tons of screen pops up on my PC on top of that it does not work it needs to be fixs!

  58. Pinta December 16th, 2012 8:39 am

    After installing last Version PlexMediaServer-0.9.7.7.339-5ec3b53-x86 for my Synology 411+ i have 404 not found error…
    any help…?

    thx.

  59. kevin December 17th, 2012 2:45 am

    Hello, when you talk about 2012 models, does it mean that the 213+ … now support plex ? :D

  60. dunky December 22nd, 2012 2:22 pm

    hello, i have bought a 213+ , does 0.9.7.7.339 work on the synology ds-213+,
    what software does i have to install the intel or the arm version

    thanks
    dunky

  61. Gabriel December 23rd, 2012 10:31 pm

    I have a blue screen when I use the Plex. The eror signature is:
    BCCode : f4 BCP1 : 00000003 BCP2 : 897B8340 BCP3 : 897B84B4
    BCP4 : 8060577E OSVer : 5_1_2600 SP : 3_0 Product : 256_1
    and the Error Report contents is:
    C:DOCUME~1GabrielLOCALS~1TempWERad57.dir00Mini122412-03.dmp
    C:DOCUME~1GabrielLOCALS~1TempWERad57.dir00sysdata.xml
    I have Windows XP profesional operating system.
    Can you fix that?

  62. John December 30th, 2012 7:52 pm

    Since the new update, in my ps3 it says that data is unsupported and on my iPhone it says unable to play media…an unknown error occurred. Everything was working great before I just did the latest update on my iMac. Any suggestions?

  63. elan December 31st, 2012 2:46 pm

    @John: Not aware of any DLNA/PS3 regressions, does the old PMS work?

  64. David Seng January 1st, 2013 1:44 pm

    Hi Elan,

    I installed 9.7.7 on my Synology 1511+ , I can’t access plex media manager thru port 32400 now. Any suggestions to resolve this ? Thanks

    David

  65. elan January 2nd, 2013 3:55 pm

    @David: I don’t have any ideas off-hand, I seem to recall some people ran into an issue when they had the Ethernet cable plugged in to a secondary port, but I could be totally off-base. I recommend you double-check the server is running, and then see if you can hit http://x.x.x.x:32400/

  66. Christiano Debarry January 4th, 2013 1:49 pm

    Just awesome software. Congratulations guys!!! Any info regarding subtitles, wdtv live and transcoding? I cant load external subtitles yet.

  67. Rick January 6th, 2013 3:57 pm

    This is making my LG 47LM6400 TV constantly reboot every 30 seconds.

  68. Mavrodi Kirriakov January 8th, 2013 2:38 am

    I have the same problem. My LG 47LM670S reboots every time when found Plex server. It worked fine with old version of Plex.

  69. Sheldon January 8th, 2013 2:48 am

    Rick, I also have an LG 47lm6400 that is rebooting about every 30 seconds after the network connection drops. This happens when running Media Link from the TV. If I go to the PC and Close Plex Media Server all is fine after opening and closing TV.
    Until the connection fails I am able to watch a movie for a while.I Got the TV Dec 30, 2012 and did update to latest PLEX software. Think older version did not have that problem. It seemed to start after upgrading to newest version. I tried Windows Media player to stream and MP4 movies work fine, however WMP does not support MKV. TV does not reboot unless Plex server running and I play the movie and connection fails after a while. I have a Dlink DIR625 router which is working fine for accessing youtube, internet.

  70. drftg January 8th, 2013 4:16 am

    I had to disable Plex (0.9.7.7) on my ReadyNas as it is causing a constant reboot on my LM670s ;(

  71. elan January 8th, 2013 11:24 am

    We’re attempting to get an answer from LG, since we’ve heard that older versions cause the reboot issue as well. If anyone has data points to share, please drop me an email! Together we’ll figure this out :)

  72. Виталий January 9th, 2013 7:12 am

    After the upgrade, Plex (0.9.7.7) my TV 3D LED LG 42LM620T began constantly reboot. With the previous version of Plex (0.9.6.9) everything was normal.

  73. elan January 9th, 2013 3:34 pm

    @Виталий ~ we’ve been working with LG to resolve, and will be pushing a media server with a workaround which will prevent the TV from rebooting.

  74. Bob January 9th, 2013 6:18 pm

    Do you guys ever check YOUR forums?…apparently not, since NO ONE from Plex has had the courtesy to address the hundreds of posts concerning the LG rebooting issue!…bad business

    FYI, I was running 0.9.707 before the latest update to 0.9.709, and was NOT having the reboots every 10 seconds

  75. elan January 9th, 2013 8:41 pm

    @Bob: We’ve commented on the matter in here (blog) and in the forums. We’ve been working with LG to resolve, and will be pushing a media server with a workaround which will prevent the TV from rebooting.

  76. Jemma January 10th, 2013 12:15 am

    Where have u commented in your forums. All I see is cries for help from your users but not one plex representative saying diddly squat on their forums. The day I started to pay for your product via medialink is the day I started to expect a little more support.

  77. elan January 10th, 2013 2:18 pm

    Dear Jemma: The thread is here http://forums.plexapp.com/index.php/topic/56097-plex-causing-lg-tvs-to-reboot/page__view__findpost__p__338250 (I’ve linked you towards the end, but I commented multiple times in that thread). I’m also slightly confused. MediaLink is an LG product, you didn’t pay us for it. And the reboot is a software bug in the LG TV, we released a workaround to stop it from happening.

  78. Stefan January 13th, 2013 9:20 pm

    Dear Elan,

    I can not seem to access the link you’ve posted ”http://forums.plexapp.com/index.php/topic/56097-plex-causing-lg-tvs-to-reboot/page__view__findpost__p__338250”

    It keeps saying:”[#10342] We could not determine which forum this topic is in. ”

    Please help cause I’d love for this problem to be solved also for my LG tv.

    Thanks in advance!

  79. elan January 14th, 2013 9:37 am

    @Stefan: sorry about that, just grab the release off http://www.plexapp.com/getplex and it’ll solve the reboot issue.

  80. JinJapan January 14th, 2013 8:38 pm

    Impressive. Advid fan of Plex and the service it provides. Thank you for the hard work and dedication to detailed development. You have made this particular home entertainment user and enthusiast very happy.

  81. Jeff January 19th, 2013 4:11 am

    Plex media server has been broken on my maco os x 10.8.2 for 2 weeks. I repeatedly get python quit unexpectedly on install. Other people have this problem and have complained in the forums. Is something wrong with the build?
    http://forums.plexapp.com/index.php/topic/56249-plex-is-crashing-on-startup-v-0979375/page__p__342594__fromsearch__1#entry342594

  82. jsserver January 30th, 2013 8:31 am

    I updated Plex on my synology and nog my PS3 can’t find the server anymore. The Android app can.

  83. ob February 8th, 2013 12:04 pm

    since latest update no plex on my tv :( cant find server, cant even add folders to my library, completely messed up

  84. cathy February 27th, 2013 2:04 pm

    pls help i downloaded plex but cant setup servers?…pls help

  85. nitin March 4th, 2013 10:31 pm

    hi guys,
    anyone having problem with accessing the media manager?
    I am getting “404 Not Found” error.

    URL: http://127.0.0.1:32400/web/index.html

  86. elan March 6th, 2013 2:26 pm

    @nitin: Sounds like your server isn’t correctly published to myPlex?

  87. Franck March 8th, 2013 2:29 am

    I have got two TV, Samsung and LG. Since this update, both LG and Samsung can’t find server, can’t even add folders to my library too. Today it’s still the same problem with plex media server 0.9.712.

    Nitin, if you have a “404 error”, rigth click on Plex icon systray, choose “Update library” and try to open media manager… And you will have to do that before opening media manager at every time. It’s a crazy bug.

  88. Jeremy Waldner March 17th, 2013 9:21 am

    What we really want is to run plex media server on our older android phones, and select & control the que & playback with the plexapp on our current phone.

  89. Peter March 21st, 2013 8:40 am

    ok i have 42lw570s LG smart tv, latest version of plex media server installed that is 0.9.7.17. The problem is that my LG tv not seeying the media server all i have is cannot find server although the server is up and running on pc win8 65 bit. I tried multiple times with different luck. Bonjour/gdm on/off still no luck. It seems like it is enabled randomly because sometimes it works (when LG sees PMS it works fantastic). Most of the time i get the cannot find server message :/ any clues?? help?? will be greatly appriciated. Thank You for great work and hope i can solve this annoying connection issues.

Leave a reply