Plex 0.8.5: Fixes, fixes, fixes

11.18.09 72 Comments

The Plex/Eight series is supposed to be about stability, and with all the changes we introduced in the 0.8.3 there were a few regressions that slipped in as well. We’re very sorry about that, and we’ve worked extremely hard since it was released to fix the issues introduced as well as new ones that came to light. So what happened to 0.8.4? We were on the verge of releasing it and then found a few more bugs, so we “nuked” the release. Those of you who sniffed it out on the server, you may want to upgrade now to the real thing.

Without further ado, the fixes:

  • FIX: A bug where Plex and the Plex Media Server could get out of sync and display the wrong contents for a directory.
  • FIX: An issue when stopping music playback, where the GUI “clicks” don’t restore and the playing track is still selected.
  • FIX: Photo thumbnails were broken for plug-ins (thanks to orr721 for the report!)
  • FIX: Hitting the menu button during a blank slideshow causes a crash. (thank to Majkel and other for the report!)
  • FIX: When a track fails to play, Plex jumps into (blank) Now Playing screen anyway.
  • FIX: Sometimes the photo screensaver started going “crazy fast”.
  • FIX: The new remote code logged too much.
  • FIX: The duration didn’t show up in plug-ins.
  • FIX: You weren’t returned to the main menu correctly from items added to your Favorites, or direct links to plug-ins in the Music section. Existing favorites will need to be removed and re-added. (James)
  • FIX: The iTunes plug-in now sorts artists by the “sort artist” field in iTunes. This one is for Scott!
  • FIX: Crashes with WebKit plug-ins that appear in the Music section.
  • FIX: PlexHelper occasionally stopped responding (or responded incorrectly) to button presses.
  • FIX: Sometimes Plex didn’t start after the first run. Believe it or not, this was an OS X bug, now worked around.
  • FIX: Plex hung when using the mouse wheel to scroll through text (thanks to hqrs for the report!)
  • FIX: Changed the servers in the TVDB scraper to use the load balanced ones. (many thanks to kruisje for the fix!)
  • FIX: Fixed a crash loading some RAW files.
  • FIX: DTS-to-AC3 was broken in the last release. Thanks to our audio doctor Ryan who fixed it and improved the AC3 trancoding in the process.
  • FIX: When you select “previous track” it now does the right thing with streamed content: moving to the start of the track or the previous track depending on how far along the track is (awesome, James!)

OK, so I said there were just fixes, right? I lied! James, as usual, pulled out a great new feature or two out of his hat, and we hope you enjoy them.

  • NEW: Plug-in preferences show up on the context menu for the plug-in itself.
  • NEW: Auto-sourcing of remote Plex Media Server iLife plug-ins. Let’s say you have a laptop with iTunes music, or your wife’s iMac has iPhoto on it. No longer do you have to manually add the sources, or wonder if they’ll work when you click on them. With the new version, sources add and remove themselves auto-magically thanks to Bonjour. Make sure you install the new Plex Media Server on the remote machines.
Plex-1.jpg

I’ll leave you with a rare sighting of the Loch Ness Barkley.

Aperture-2.jpg
Share on FacebookTweet about this on TwitterShare on Google+Share on LinkedIn
Share this

72 Comments

  • Running 8.5 on OSX 10.5.8, just recently I can’t seem to get all my movies to scrape properly. I just get 100s of titles saying “Movies” and a rating of 1.90! I haven’t had any problems before with naming conventions etc. Any clues?

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>